InstallationΒΆ

Phinx should be installed using Composer, which is a tool for dependency management in PHP. Please visit the Composer website for more information.

Note

Phinx requires at least PHP 5.4 (or later).

To install Phinx, simply require it using Composer:

php composer.phar require robmorgan/phinx

Create folders in your project following the structure db/migrations with adequate permissions. It is where your migration files will live and should be writable.

Phinx can now be executed from within your project:

vendor/bin/phinx init